No Power from my new Helix! (with solution)

A place to discuss matters related to Honda Helix scooters.

No Power from my new Helix! (with solution)

Postby Squeazel » Thu Nov 08, 2018 5:30 pm

Hi, Forumites, new Helix owner here. I have a hobby of buying old scooters with problems, and fixing them up and selling them at a discount. It's cheaper than most other hobbies because I actually make a little profit (probably about $1.50 an hour :lol: :lol: )

Anyway, I bought a 2001 Helix that seemed to run fine, but it just didn't have any power. Like somebody left the corral open and about 2/3 of the horses escaped. It was plenty smooth at idle, no funny noises or smoking, and ran fine for the first quarter turn of the throttle, but opening it any more wouldn't make it go any faster. Limited to about 30 MPH. 8000 miles and easy starting so it wasn't anything like valves or a hole in the piston.

I didn't think it was electrical since it didn't miss at any rpm, and fuel starvation from a clogged fuel filter or jet would have completely stopped the engine (zero power- stall) when the throttle was opened wide. I suspected the slide diaphragm was split, and sure enough somebody had opened the top of the carb and put the diaphragm in crooked, so it was leaking around the edge. I reinstalled the diaphragm and all the horses came back! Whoo hoo! Easy solution!
Squeazel
 
Posts: 9
Joined: Mon Nov 05, 2018 2:54 pm

Re: No Power from my new Helix! (with solution)

Postby Cruiser » Thu Nov 08, 2018 6:51 pm

Excellent! Have to remember that fix.
User avatar
Cruiser
 
Posts: 2265
Joined: Fri May 09, 2008 8:50 pm
Location: West Ohio 45828


Return to Honda Helix

Who is online

Users browsing this forum: No registered users and 2 guests